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1 SAFR Geutebrueck Integration Guide
Integrated SAFR Geutebrueck is only available on Windows.

Integrating SAFR’s facial recognition and analysis capabilities into Geutebrueck enables you to use SAFR’s
video feed information overlays within Geutebrueck camera video feeds, thus making it much easier to quickly
and accurately separate unknown people from authorized people from known threats. You’ll also have
immediate access to additional infomation such as age, gender, sentiment, name, company, known associates,
or any other configurable information you want to create.

Integrating the two systems also allows SAFR’s information-rich events to trigger and populate Geutebrueck
events, alerts, and videotagging/bookmarking.

A final benefit to integrating SAFR and Geutebrueck is that you’ll be able to enroll individuals appearing in
Geutebrueck cameras into SAFR’s Identity Database.

1.1 Integration Overview
A typical deployment requires the following:

• A machine running Geutebrueck G-Core.
• One or more machines running the SAFR Desktop Client to process videos.
• If you’re doing a SAFR on-premises deployment, you’ll also need a machine running SAFR Server.
SAFR Server can run on the same machine as one of the Desktop Clients, provided the host machine
meets the system requirements.

Cameras are connected to the Geutebrueck G-Core. The SAFR Desktop Client can then connect to the
G-Core to perform analysis of the video and add overlays. Depending on the number of cameras you need,
one or more machines may be required to run the SAFR Desktop Client(s), each processing multiple video
feeds. The Desktop Client is also used to perform various management activities.

1.2 Install and Configure Geutebrueck
1.2.1 Install G-Core

1. Download the latest G-Core installer from the Geutebrueck Download Portal.
2. Run the installer, selecting the following options during installation:

• Select all of the IP cameras.
• Select Plugin > GBF Streamer.
• Select Plugin > Media Channel Simulator.
• Select Plugin > Livestream Reader.

1.2.2 Add a SAFR User Account

You’ll need to create a user account within Geutebrueck that SAFR will use to connect to Geutebrueck. To
do this, do the following:

1. Open the G-Set application.
2. Go to General settings -> User.
3. On the User configuration window on the right, click on the Add button in the upper left corner of

the window.
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4. Enter a name and password for the new account.

5. The new account will now be listed among the list of created user accounts.
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1.2.3 Add a Camera

To add and configure a new camera to Geutebrueck, do the following:

1. Open the G-Set application.
2. Go to Media channels/Hardware -> Hardware. (#1 below)
3. Click on the Add button at the top of the Hardware configuration window. Select the type of

camera you want to add from the list of IP camera plugins. A new IP camera plugin entry will appear
in the Hardware module list. (#2 below)

4. Click on your new camera plugin entry. The right pane wll now display various settings for the new
plugin.

5. Enter the IP address for your camera as well as the credentials for its RTSP port, if applicable. (#3 below)

6. Go to Media channels/Hardware -> Media channels. (#1 below)
7. Click on Add Media Channel. (#4 below)
8. Click Add to add a new media channel. (#5 below)
9. The hardware you just added will be colored red since it’s not yet selected or enabled. (#6 below)

10. Click on Permanent recording for the camera plugin you just added. (#2 below)

5



11. Tick the Permanent recording checkbox. (#3 below) This enables Geutebrueck to display reference
images and event images.

12. Go to Media channels/Hardware -> Hardware.
13. Click on the Add button at the top of theHardware configuration window. Select Plugin <Direct

Image Feed Plugin> from the list of plugins, then press Add. A new IP plugin entry will appear in
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the Hardware module list. (#1 below)
14. Click on the new plugin.
15. Set the MediaChannelID of the MappedMediaChannel to the camera that’s being used. (#2 below)
16. Select Send Setup to Server from the File drop-down menu at the top of the window.

1.2.4 Configure Geutebrueck Events

To add and configure a new Geutebrueck event type, do the following:

1. Open the G-Set application.
2. Go to Events/Behaviour rules > Events, (#1 below)
3. Click on the Add button at the top of the Event Configuraton window. Your new event type will

appear on the Event list. (#2 below)
4. Click on your new event type. The right pane wll now display various settings for your new event type.
5. Select the Event tab, if it’s not already selected.
6. Enter a name for your new event type. (#3 below)
7. Tick the Active and Event run time checkboxes. (#4 and #6 below, respectively)
8. Select Start new instance from Retrigger mode’s drop-down menu. (#5 below)

9. Select the Alarm tab. (#1 below)
10. Tick the Active checkbox. (#2 below)
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11. Select the Media channels tab. (#3 below)
12. Click on the Add button on the right of the Media channels window and select one of the listed

cameras. The selected camera will now be a media channel for this alarm. (#4 below)
13. Tick the Live checkbox. (#5 below)

14. In the Event list, click on Recording tasks for your new event type. (#1 below) This will cause a
new Recording task tab to appear on the right pane. Select that new tab.

15. Select the Media channels tab, if not already selected.
16. Click on the Add button on the right of the Media channels window and select one of the listed

cameras. The selected camera will now be listed in the Media channels window. (#2 below)
17. Tick the Record channel checkbox. (#3 below)
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18. In the Event list, click on StartBy for your new event type. (#1 below)
19. Click on the Add button near the top of the Event configuration window.
20. You will be prompted to select whivch action to add. Choose Face Recognition Result.
21. In the Event list, click on the newly added Face Recognition Result.
22. In the Settings window in the right pane, tick the channel checkbox.
23. Select the media channel that you added in the previous steps from channel’s drop-down menu. (#2

below)

1.3 Install and Configure SAFR
To install SAFR, do the following:

1. Go to the SAFR Download Portal.
2. If you’re doing a cloud deployment, download and install Windows SAFR Desktop. Make sure to select

the Geutebrueck install option.
3. If you’re doing an on-premises deployment, download and install Windows SAFR Platform. Make sure

to select the Geutebrueck install option.
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• When installing the SAFR Platform, the default SAFR port assignments sometimes conflict with
other software port assignments. If a port conflict occurs, the error message shown below will pop
up in the middle of your installation.

If this happens, do the following:

1. Click OK to edit port configurations.
2. Notepad will open, displaying the safrports.conf file.
3. Edit any conflicting ports to new values. (e.g. CoviHTTP=18080)
4. Save and exit Notepad.

The Platform installer will then restart and the new port values will be used. You can find the modified
safrports.conf file at C:\Program Files\RealNetworks\SAFR\.

After the installation finishes, two icons will appear on your desktop: one labeled SAFRActions and another
labeled SAFR. SAFRActions launches SAFR Actions, while SAFR launches the Desktop Client. The SAFR
Server (when installed as part of a local deployment) automatically runs as a collection of background services.

Immediately following installation, the installer opens the Desktop Client and prompts you to log in with
your SAFR Account credentials. Make sure to log in; it’s important in acquiring the SAFR license.

1.3.1 Connect SAFR to Geutebrueck

To connect SAFR to Geutebrueck, do the following:

1. Within your SAFR Desktop Client, select Tools->Preferences->Geutebrueck.
2. Enter information for the first three settings on the SAFR Geutebrueck Preferences menu: Server,

Username, and Password. See below for information about the available SAFR Geutebrueck preference
settings.

1.3.1.1 SAFR Geutebrueck Preferences You can configure several Geutebrueck-specific settings from
the Tools->Preferences->Geutebrueck menu.

10



• Server: IP address or hostname of a Geutebrueck server.
• Username: Username of a Geutebrueck user that has sufficient permissions to allow SAFR to connect
to the Geutebrueck system. See the Add a SAFR User Account section above for information about
how to create and find this information.

• Password: Password of a Geutebrueck user that has sufficient permissions to allow SAFR to connect
to the Geutebrueck system. See the Add a SAFR User Account section above for information about
how to create and find this information.

• Update Events: Specifies if generated events should be updated if additional information is obtained.
(e.g. A previously unidentified face becomes recognized, possibly due to improved lighting conditions,
thus changing a Stranger Event to a Known Person Event.)

• Update Interval: If Update Events is enabled, this setting specifies how frequently events are
updated.

• Allow enrollment of low quality images: Enables enrollment of people with low quality facial
images. See the Image Quality Metrics Guidance page in the SAFR documentation for information
about face image quality.

• Insert Events: Enables insertion of events into Geutebrueck.
• Include Unrecognizable Faces: Enables the inclusion of events triggered by unrecognizable
faces.

• Include Strangers: Enables the inclusion of events triggered by strangers.
• Include Enrolled: Enables the inclusion of events triggered by enrolled persons that aren’t
persons of concern or known threats.

11

https://docs.real.com/guides/safrdocs/Image_Quality_Metrics_Guidance.html


• Include Concerns and Threats: Enables the inclusion of events triggered by persons of concern
or known threats.

• Include Event Images: Enables the inclusion of event images.
• Include Recognized: Enables reference and event face images for events triggered by recognized
persons.

• Include Strangers: Enables events face images for events triggered by strangers.

1.3.2 Verify the Connection to Geutebrueck

To verify that your SAFR system successfully connected to the Geutebrueck system, do the following:

1. Open the Camera Feed Analyzer in the SAFR Desktop Client.
2. Click on the camera selection drop-down menu at the top of the Camera Feed Analyzer.

3. You should see the cameras connected to Geutebrueck among the available camera. Note: All
Geutebrueck cameras will have "Geutebrueck" appended to the beginning of the camera name.

• If you don’t see any Geutebrueck cameras listed, try shutting down and then restarting your SAFR
Desktop Client.
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2 SAFR Geutebrueck Operation Guide
2.1 Person Enrollment
Most of the integrated SAFR Geutebrueck functionality requires that people are first enrolled in SAFR’s
Identity Database. There are 3 main ways that people can become enrolled in your SAFR system:

• Import people into SAFR using photos of faces.
• Import people into SAFR using video files. (e.g. saved CCTV footage)
• Enroll people into SAFR from within the Geutebrueck G-View client, as described in the section below.

2.1.1 Enroll People from Within Geutebrueck

To enroll people into SAFR from within Geutebrueck, do the following:

1. Open the Geutebrueck G-View client and run a recorded CCTV video file.

2. Click the button to enter Face Enrollment mode.
3. Draw a rectangle around the face to be enrolled.
4. Click the Enroll button. This will cause the person’s face to be enrolled in SAFR.

2.2 Video Overlays
Geutebrueck supports displaying real-time overlays in the G-View Client and archived video on a periodic
basis. The frequency and duration of display is managed in the G-View preferences. When SAFR and
Geutebrueck are integrated, Geutebrueck’s video overlays display additional information.
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Geutebrueck Overlay Item SAFR Equivalent Additional Notes
ID PersonId If the person isn’t enrolled in

SAFR, this field is blank.
(Persons who aren’t enrolled
don’t have PersonIds.)

Name Last Name
FirstName First Name
Group Person Type
Info Tags This item is a boolean. It’s set

to true if the viewed person is
enrolled in SAFR and has one or
more tags defined. Otherwise,
it’s set to false.

CardNo N/A This item currently isn’t used
for anything.

Confidence similarityScore
Gender Gender This item is an integer; its

possible values represent the
following:
0 = Female
1 = Male
2 = Unknown

Age Age
Time DateTimeOffset
String 1 External Id
String 2 Id Class This item is a text string.

14



Geutebrueck Overlay Item SAFR Equivalent Additional Notes
Integer1 Id Class This item is an integer; its

possible values represent the
following SAFR Id Classes:
0 = Unknown
1 = Unidentified
2 = Stranger
3 = NoConcern
4 = Concern
5 = Threat

Integer2 Sentiment value
Double1 Mask This item is an integer; its

possible values represent the
following:
0 = no mask
1 = masked face

Double2 SAFR Event Type This item is an integer; its
possible values represent the
following SAFR event types:
0 = Unknown
1 = Person
2 = Badge
3 = Action
4 = RecognizedObject

See the SAFR documentation for details about the additional overlay information.
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