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INTRODUCTION TO REALSLIDESHOW
Welcome to RealSlideshow version 2.0 Powered by RealSystem G2. 
RealSlideshow allows you to convert basic image files into streaming 
media presentations for use on the World Wide Web or a corporate 
Intranet. Combining RealPix™ with RealAudio® opens up a whole 
new dimension to your images.

Main Features
With RealSlideshow, you can:

• organize images on a timeline

• add background music

• add your voice to describe your images

• customize the look of your images and your RealSlideshow presentation

• send the RealSlideshow presentation to your friends and family

Features in the Plus Version
The following features are also available if you purchased the Plus version of 
this product:

• add clickable hyper-links to your presentation

• add text to describe your images

• add new text and logo regions to your RealSlideshow presentation

• change the layout of the final presentation and save it as a template
1
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About This Manual
Chapter 1: Installing RealSlideshow explains installation procedures and 
provides information about system requirements for installing and using 
RealSlideshow.

Chapter 2: Slide Show Basics contains general information about streaming 
media and RealSystem G2. It describes the different components of a 
streaming media presentation (including SMIL) and is recommended 
regardless of whether you are new to RealSystem G2 or an experienced content 
creator.

Chapter 3: Getting Started shows you how to open RealSlideshow and create a 
new project.

Chapter 4: Adding Images shows you how to add images to your project and 
customize them.

Chapter 5: Adding an Audio Track shows you how to add audio to your 
presentation, both recorded music and a voice narration.

Chapter 6: Adjusting Project Properties explains how to modify your project. 
You will learn how to add a title and other unique information, adjust the 
layout (Plus version only), and change your target audience.

Chapter 7: Generate the Presentation shows you how to create the final 
presentation, play it, publish it, and send it to your friends and family.

For More Information
For additional information about using streaming media effectively and how 
to create different types of multimedia presentations, refer to the RealSystem 
G2 Production Guide, available for download from the RealNetworks Web site 
at:

• http://service.real.com/help/library/index.html

For technical support with RealSystem G2, please fill out the form at:

• http://service.real.com/contact/email.htm

The information you provide in this form will help technical support 
personnel to give you a prompt response. For general information about 
RealNetworks' technical support, visit:

• http://service.real.com/help/call.html
2
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 Chapter 1: INSTALLING REALSLIDESHOW
This chapter details requirements needed by your system to run 
RealSlideshow and also provides step-by-step installation 
instructions. You will also learn what other equipment and software 
you need to create a multimedia presentation.

System Requirements
RealSlideshow is currently available for the following operating systems:

• Microsoft Windows 95® (OSR-2)

• Microsoft Windows 98®

• Microsoft Windows NT® 4.0 (Service Pack 3)

In addition, you need the following hardware to run RealSlideshow:

Other Requirements
You will need the following installed in order to use RealSlideshow:

• RealPlayer™ G2

Hardware Requirements

Requirement Minimum Recommended

CPU Pentium® 120 Pentium® 166 with 
MMX

RAM 32 MB 48 MB

Hard Disk space 
(software)

30 MB

Hard Disk space (data) 30 MB 100 MB

Color Display 16-bit (High Color) set to 800 x 600 resolution

Sound Card 16-bit sound card or better
3
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• a compatible Internet browser, such as Netscape Navigator™ v 3.0 or later, 
or Microsoft Internet Explorer™ v 3.02 or later

• a microphone, if you plan on recording your voice for narration

• speakers or a set of headphones connected to your sound card

How to Install
This section shows you how to install and register the product on your 
computer.

➤ To install RealSlideshow:

1. Insert the RealSlideshow compact disc in your CD-ROM drive, or 
download the install program if you purchased the product from the 
RealNetworks Web site.

2. Close all open programs.

3. Double-click the install program to begin installation.

4. Inspect the Program License Agreement, and click Accept to agree.

5. Enter your e-mail address.

6. Choose a destination directory location or accept the default location.

7. Enter the serial number that is included with your purchase of 
RealSlideshow, and click Next.

8. Select Yes or No when asked if you want to add a desktop shortcut to 
RealSlideshow.

9. Click Finish to begin installation.

10. After installation is completed, click Yes or No when asked if you want to 
view the product’s ReadMe file.

This file contains important information about the product that could 
not be added to this document before publication.

11. Fill out the electronic registration and select whether you want to be 
informed of any RealSlideshow updates or events.

12. Click Next.

13. You can run a guided tour that introduces you to RealSlideshow, or you 
can run the program.
4
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 Chapter 2: SLIDE SHOW BASICS
This chapter introduces you to streaming media and shows you the 
different parts of a streaming media presentation. Although you do 
not need to know this information in order to use RealSlideshow for 
basic tasks, it is recommended that you have a working knowledge 
of these topics.

What is Streaming Media?
Before the advent of streaming media, you had to wait for a media file to 
completely download from an Internet or network server in order to 
experience it. When you create a streaming media presentation, users can view 
it almost instantly with a RealPlayer G2.

Streaming media allows you to send small packets of information over a 
network connection. The user receives the information packets and plays your 
media piece by piece. The process is almost invisible to the user, except for a 
small amount of buffering at the beginning.

RealSlideshow G2 is a part of the RealNetworks RealSystem G2. 
RealSlideshow creates the presentations, RealServer™ G2 sends them across 
the Internet, and RealPlayer™ G2 shows them to the user.

Components of a Streaming Media Presentation
A presentation created with RealSlideshow can include images and audio in a 
layout designed for streaming to RealPlayer G2. Both of these media elements 
are synchronized together to create a rich, multimedia presentation.

This section introduces you to the different components that can make up a 
streaming media presentation created with RealSlideshow.
5
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Images

A presentation created with RealSlideshow contains a collection of images 
that is the focus of the author’s show. RealSlideshow converts your JPEG 
(.jpg), GIF (.gif), PNG (.png), or bitmap (.bmp) images into streaming media. 
These images are combined with your audio narration to create a streaming 
media presentation that is shown in a RealPlayer G2.

For help on creating good images before you place them into RealSlideshow, 
see “Tips on Creating Images” on page 9.

Audio

Clear and good-sounding audio in a presentation can greatly improve a user’s 
experience. Your audio input, whether by microphone or a recording of a 
compact disc, is converted into RealAudio and streamed along with your final 
presentation.

Text

You can use RealSlideshow to add text to a presentation by adding a caption. 
A caption is streaming text (also known as RealText) that reads along with a 
slide.

Streaming text is a good way to describe your slides. You can use streaming 
text to create messages, a running commentary, or captions for your images.

Putting it All Together
A layout brings all of these streaming media elements together. RealSystem 
G2 uses the SMIL (pronounced “smile”) mark-up language to create the layout 
for your presentation.

RealSlideshow allows you to use a basic, default layout, or you can combine 
the slides with other media, such as text and logos, to create your own custom 
presentation. See “Choosing a Layout” on page 31 for more information on 
creating a layout.

Refer to the RealSystem G2 Production Guide, available from RealNetworks, if 
you want to learn more about the SMIL language.
6
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 Chapter 3: GETTING STARTED
This chapter shows you how to begin using RealSlideshow. You will 
learn how to start the product and create a new project. Also 
included is a tour of the main window where you will do all of your 
work.

Overview of the Main Window
As with most Windows programs, you can start the program from the 
Windows Start menu. Click on Start>RealSlideshow to begin.

Once you have started the product, the main window opens for you. This 
section gives you a brief tour of the main window, introducing each element to 
you.

The RealSlideshow Main Window

Main Menu—the primary way to access different functions of this program
7
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Storyboard—a graphic representation of the different elements of your 
presentation; the main sections are: Images, Download, Voice, Music, and the 
Timeline

Properties button—this button allows you to change options for the current 
project

Layout button—this button allows you to adjust the layout of the final 
presentation

Production buttons—use these buttons when your presentation is ready to be 
created; you can generate your presentation, play it, and send it to your friends 
and family

Creating a New Project
The first step in creating a streaming media presentation is creating a new 
project. This project file contains all of the information about your 
presentation: the images you use, the audio track, and other preferences. All of 
this information is saved as a single project file so you can work with it at any 
time.

The project files you create with RealSlideshow have a .rpj extension.

➤ To create a new project:

1. In the main window, choose File>New Project.

An untitled project opens in the main window.

2. Choose File>Save Project As.

3. Enter a name for your project and a directory where you want to save it. 
Make sure you use the .rpj extension.

4. Click Save to save the project and return to the main window.
8
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 Chapter 4: ADDING IMAGES
Streaming images are the main focus of a RealSlideshow 
presentation. This chapter describes general tips on creating images, 
shows you how to add images to your project, and describes how to 
customize the images to create a quality presentation.

Tips on Creating Images
Using high-quality images in your RealSlideshow presentation is one of best 
ways to create a great slide show. Because there are a number of ways that you 
can create images (digital camera, scanning photos, scanning slides, for 
example), image quality can vary greatly depending on your particular 
method.

Regardless of how you create your original, you should try to make sure your 
digital image has the following qualities:

• maximum resolution of 96 dpi (dots per inch)

• maximum file size of 150k

Any image with higher resolution or a larger size will decrease your 
performance without greatly enhancing your slide show. You may have to 
experiment with different graphics programs to get a file that works best. 
Most importantly, make sure to back up your original image file.

Adding and Deleting Images
This section shows you how to add images to your presentation or remove 
them. The types of images that are accepted are JPEG (.jpg or .jpeg), GIF (.gif), 
PNG (.png), or Bitmap (.bmp) files. In this step, you select the images you 
want and place them on the storyboard.

➤ To add images to your presentation:

1. In the main window, choose File>Add Images.
9
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The Add Images to Project dialog opens.

2. Change the directory to locate the image file you want to add.

3. Select the image file, or press CTRL and select more than one image file.

You can see the selected image in the Preview area.

4. Click the Open button.

The image is added to the storyboard. If you have other images present, 
the current image is added to the end of the presentation.

5. Repeat the above steps for all images you want to add.

Tip
You can also simply drag image files from a folder and 
drop them directly onto the storyboard.

➤ To delete an image:

1. Select an image in the Image storyboard, or press CTRL and select more 
than one image.

2. Choose Edit>Delete from the main menu.

The image is erased from the storyboard and the project.

Changing Download Time
Since images are the primary part of a presentation created with 
RealSlideshow, the quality of the images is extremely important. This section 
gives you a few tips so that your images are ready for streaming.

Image files added to your project appear in the Images section of the 
storyboard. There are two attributes to an image, the time needed to 
download the image and the time the image appears in the presentation.
10



RealSlideshow User’s Guide CHAPTER 4: Adding Images
Close-Up of Image

When an image “downloads” in RealSlideshow, it has a different meaning 
than ordinary downloads. Ordinarily, you would have to wait for the entire 
presentation to download before you could view it. RealSlideshow arranges 
the download time of each image to coordinate with the display time of 
another image. Therefore, the downloading is mostly invisible to the audience. 
The download time depends on the size of the image and the connection 
speed of your audience. See “About Bandwidth” on page 36 for more 
information.

Note that images are downloaded while the previous image appears. In other 
words, there is a minimum time that an image can show, because the next 
image is downloading. RealSlideshow keeps track of this download time 
automatically and will not allow you to show an image less than the 
minimum.

If you want to decrease the time needed to download an image, you can adjust 
how much that image is compressed by RealSlideshow when the final 
presentation is created. You can also decrease download time by cropping out 
unwanted portions of an image. See “Changing the Look” on page 17 for more 
information.

➤ To adjust the compression for an image:

1. In the Image storyboard, select an image.

Tip
To select an image you want to adjust, click it with the 
mouse or use the arrow keys on your keyboard.
11
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2. Choose Edit>Image Properties from the main menu.

3. Click the Edit tab.

A preview of the selected image appears on the right, and the original 
image source appears on the left.

4. In the Compression section of the dialog, choose the type of image you are 
adding:

• Photograph—images scanned from normal photographs or taken 
with a digital camera

• Graphic—images generated using computer graphics programs, or 
digital art

5. Move the Compression slider towards Fast Download to decrease 
download time.
12
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Notice that the image in the preview window will lose clarity the more you 
decrease the download time. This is how the image will appear in the final 
presentation.

6. Click OK to apply your changes to the project.

Changing Transitions
A transition is a visual effect that takes place when the presentation moves 
from one image to another. By default, each image fades into the next one. If 
you want to change how two images transition, the following table describes 
the different types of transitions you can use.

➤ To change a transition:

1. In the Image storyboard, select an image.

Tip
To select an image you want to adjust, click it with the 
mouse or use the arrow keys on your keyboard.

2. Choose Edit>Image Properties from the main menu.

3. Click on the Transition tab.

The Transition page opens. A preview of the image is shown.

Image Transitions

Type Description

Fade The new image gradually fades in 
while the old image fades out; used 
when a subtle change is wanted.

Wipe The new image moves over the old 
image; you can specify which direction 
the new image wipes from.

Push The new image pushes the old image 
away; you can specify which direction 
the new image pushes from.
13
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4. Select a new transition type.

5. Enter the time for the transition to take place. We recommend that you 
keep your transitions under 5 seconds.

6. Click the Play button to preview the new transition. Click Stop when you 
are finished previewing.

7. If you are satisfied with the result, click the OK button to return to the 
main window.

Adding Text to an Image
At times you may want to add a brief description of an image while it is shown 
to your audience. You can add streaming text to any image you choose. When 
14
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your audience plays your presentation, the text appears in a small caption area 
with the image.

➤ To add a text caption to an image:

1. In the Image storyboard, select an image.

Tip
To select an image you want to adjust, click it with the 
mouse or use the arrow keys on your keyboard.

2. Choose Edit>Image Properties from the main menu.

3. Click on the Text and Audio Captions tab.

The Text and Audio Captions page opens.

4. In the space provided, type in the text you want to appear when the image 
plays in your presentation.
15
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5. If you are satisfied with the result, click the OK button to return to the 
main window.

Changing Image Order, Time, and Look
Changing the transition between two images is only one way that you can 
customize your presentation. You can also move images around, increase or 
decrease the amount of time they play, and change how each image looks.

Changing Order

Once you have added an image to the storyboard, you may want to move it at a 
later time. RealSlideshow allows you to change the order of your images.

➤ To change the position of an image:

1. In the Image storyboard, select an image.

Tip
To select an image you want to adjust, click it with the 
mouse or use the arrow keys on your keyboard.

2. Click and hold the mouse button on the image, and drag it to a new 
location.

Tip
You can also use the keyboard to cut and paste images. 
Press CTRL+X to cut, and press CTRL+V to paste.

Changing Time

You can adjust how long an image (or the title screen) will appear in the final 
presentation. Depending on the time needed to download the next image, you 
will notice that each image requires a minimum display time. The maximum 
time you can show an image has no limit.

➤ To adjust the appearance time for an image:

1. In the Image storyboard, select an image.

The black bars at the front and back of the image show when the image 
begins and ends.
16
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Tip
To select an image you want to adjust, click it with the 
mouse or use the arrow keys on your keyboard.

2. Click and hold a black bar until you see a red line on the timeline.

3. Holding down the mouse button, drag the red line to the new position on 
the storyboard.

RealSlideshow does not allow you to drag the start of an image past the 
minimum download time.

Tip
You can also use the keyboard to adjust appearance 
time. Press CTRL+Right Arrow to increase time, and 
press CTRL+Left Arrow to decrease time.

Changing the Look

Sometimes, you want to alter the way the source image looks in your final 
presentation. RealSlideshow allows you to crop, rotate, and flip any image in 
your project.

Cropping

When you crop an image, you are removing the unwanted portions of an 
image. For example, you may want to focus on only one person in a photo. But 
your subject is in the middle of the photo and is surrounded by other people. 
In this case, you would crop around your subject.

Some things to consider when cropping:

• If you change the ratio of height to width (the aspect ratio), a black border 
will fill in any extra space.

• You can also focus on a part of the image by cropping, but keep the 
original aspect ratio.

➤ To crop an image:

1. In the Image storyboard, select an image.

2. Choose Edit>Image Properties from the main menu.

3. Click the Edit tab.
17
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A preview of the selected image appears, plus the original image source 
appears.

4. In the original image area, select a crop handle and drag it to the desired 
location.

5. You can also move the cropped area by selecting the middle of the area 
and dragging the crop outline to the desired location.

The preview area shows how the cropped image looks. The download time 
for your image can be decreased by cropping.

6. Click OK to return to the main window.

Rotating

Rotating an image turns it one quarter of a turn either clockwise or counter-
clockwise. Everything else about the image remains the same.

➤ To rotate an image:

1. In the Image storyboard, select an image.

2. Choose Edit>Image Properties from the main menu.

3. Click the Edit tab.

A preview of the selected image appears, plus the original image source 
appears.

4. Click either the Clockwise button or the Counter-clockwise button to 
rotate the image.

The preview area shows how the rotated image looks.

5. Click OK to return to the main window.

Flipping

Flipping an image means that you reverse the image over a center line. 
Flipping over its horizontal center line turns the image upside down. Flipping 
over its vertical center line creates a mirror image.

➤ To flip an image:

1. In the Image storyboard, select an image.

2. Choose Edit>Image Properties from the main menu.

3. Click the Edit tab.
18
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A preview of the selected image appears, plus the original image source 
appears.

4. Click either the Mirror Flip button or the Upside Down button to change 
the image.

The preview area shows how the new image looks.

5. Click OK to return to the main window.

Adding a Link to an Image
You can specify an URL for any image you add to your project. When the 
presentation plays in your user’s RealPlayer, he or she can click on the image. 
Once the image is clicked, his or her Internet browser starts and opens to the 
Web page you specify.

➤ To add an URL link to an image:

1. In the Image storyboard, select an image.

2. Choose Edit>Image Properties from the main menu.

3. Click the Info tab.

A preview of the selected image appears, plus some information about the 
image.
19
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4. In the space provided, enter an URL. You must enter the full address (for 
example, http://www.real.com/products/tools/slideshow/index.html).

5. Click OK to return to the main window.
20
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 Chapter 5: ADDING AN AUDIO TRACK
This chapter shows you how to add audio to your RealSlideshow 
presentation. An audio track gives your presentation another 
dimension and gives you more creative power.

There are two kinds of audio you can add to your presentation: 
music and narration. You will learn about both kinds in this 
chapter. You will first learn how to check recording levels for your 
audio in order to create an effective audio track.

Recording Levels
Before you begin to record, you should make sure that your audio recording 
levels are where you want them. An “audio level” is a technical way to say 
“volume.”

Whenever a professional audio technician records audio, he or she will always 
check the levels for every recording device using a mixer. Since you probably 
don’t have a mixer attached to your computer, you need to use the Windows 
version. The following procedure shows you how to check your recording 
levels in Windows. You will need speakers or headphones to help you listen to 
the levels.

➤ To check your audio recording levels:

1. Select Programs>Accessories>Mulitmedia>Volume Control from the 
Windows Start menu.
21
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The Volume Control window opens.

2. In the Volume Control window, select Properties from the Options 
menu.

The Properties window displays.
22
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3. Select Recording to adjust the input recording volume. (The Playback 
option adjusts the level of the volume you hear while you are recording, 
not the volume RealSlideshow uses.)

4. From the list of volume controls, select the type of inputs you will be 
using and click OK.

The Recording Control window opens.

5. Select which recording inputs to use by choosing the Select box for each 
input.

6. Adjust the sound level by moving the sliders up or down.

Remember, if the volume is too high, the recorded sound may be clipped 
and appear distorted. If the volume is too low, it will be difficult to hear.

7. Close the Recording Control window and return to the RealSlideshow.

Adding Background Music
RealSlideshow allows you to add background music to accompany your slides. 
Music from a compact disk (CD) or from certain music files can be easily 
converted to RealAudio and streamed along with your final presentation.
23
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Warning
Be sure you obtain proper copyright permission on any 
music if you plan to use the music for any purpose other 
than private use.

Adding Music from a CD

If your music is stored on a CD, RealSlideshow gives you an easy way to add 
the music to your presentation. You can only add one CD track to a slide 
show, and that track is converted into RealAudio when the presentation is 
generated.

➤ To add background music from a CD:

1. Choose File>Add Background Music from the main menu.

The Project Properties dialog opens to the Background Music page.
24
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2. Place a music CD in your computer’s CD-ROM drive.

3. Select a track number from the list.

4. Click the Start Recording button.

5. Click the Stop Recording button when you are done recording, or wait for 
the track to end.

6. At the prompt, click OK to save your audio.

7. Click OK to return to the main window.

8. Select View>Music Track to see the music represented on the storyboard.

Adding Music from a File

Music files can be added to your presentation and RealSlideshow will convert 
the file into RealAudio when the slide show is generated. Only one music file 
can be added to a slide show, and this file must be one of the following 
formats:

• WAV—a standard format for creating music files, WAV files can be created 
by most music editing software

• MP3—a new format for sharing music files over the Internet, MP3 files 
can be generated by a number of specially-designed software programs 
such as RealNetworks’ RealJukebox. You can download this product from  
http://www.real.com/products/realjukebox/index.html on the 
RealNetworks Web site.

➤ To add background music from a music file:

1. Choose File>Add Background Music from the main menu.

The Project Properties dialog opens to the Background Music page.

2. Click the Browse button to find a WAV or MP3 file to add to your 
presentation.

3. Select the file, and click Open.

4. Click the Play button to listen to the file, and click the Stop button when 
you are done.

5. Click OK to return to the main window.

6. Select View>Music Track to see the music represented on the storyboard.
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Adding a Narration
A great way to highlight portions of your presentation is to add your own 
voice to the presentation. You must record your voice for each image that you 
want to narrate.

We recommend that you write out a script before you begin recording. Your 
narration will sound much more professional.

When adding a narration in addition to background music, check your 
recording levels for your microphone so that your narration can be heard over 
the background music. See “Recording Levels” on page 21 for more 
information.

➤ To record a narration for an image:

1. In the Image storyboard, select an image that you want to narrate.

2. Choose File>Add Caption from the main menu.

The Image Properties dialog opens to the Text and Audio Captions page. 
A preview of the selected image appears.
26



RealSlideshow User’s Guide CHAPTER 5: Adding an Audio Track
3. Get your script ready.

4. Click the Start Recording button.

5. Read your script and remember to talk slowly.

6. Once you are done recording for the image, click Stop Recording.

7. Click OK when you are told that you must save your audio as a file.

The Save Audio File As dialog opens.

8. Change the directory and enter a name for the audio file, then click Save.

The audio file is saved as a WAV file and will be converted to a RealAudio 
file when you generate the output presentation.

9. Repeat the above steps for each image you want to narrate.

10. Click OK to return to the main window.
27



CHAPTER 5: Adding an Audio Track RealSlideshow User’s Guide
11. Select View>Voice Track to see the narration represented on the 
storyboard.

Using Pre-Recorded Audio

If you want to record your music or voice before adding it to your 
presentation, you may do so. There are two main ways to use pre-recorded 
audio: use an audio device connected to your computer, or record it to a WAV 
or MP3 file and save it onto your computer.

Your audio card should have an Audio Input jack that you can use to connect 
your audio device. Then, using the same procedure for recording narration, 
play the audio when you record your narration instead of speaking into a 
microphone.

You can also use audio from an audio file to narrate your slides.

➤ To add an audio file as a narration:

1. In the Image storyboard, select an image that you want to narrate.

2. Choose File>Add Caption from the main menu.

The Image Properties dialog opens to the Audio Caption page. A preview 
of the selected image appears.

3. Enter the directory and file name for the media file, or click the Browse 
button to locate one.

4. Click the Play button to listen to the file, and click the Stop button when 
you are done.

5. Click OK to return to the main window.

The audio file will be converted to a RealAudio file when you generate the 
output presentation.

6. Repeat the above steps for each image you want to narrate.

7. Select View>Voice Track to see the narration represented on the 
storyboard.
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 Chapter 6: ADJUSTING PROJECT PROPERTIES
Once you have added the basic slide show elements to your project, 
you will want to customize it according to your needs. This chapter 
shows you how to add unique information to your presentation, 
how to create a layout, and how to adjust the presentation to fit 
your target audience.

Add Information to Your Presentation
Because every presentation is different, we need an easy way to distinguish one 
presentation from another. With RealSlideshow, you can add unique 
information to your project: you can add a title, author, copyright, keywords, 
description, and an audience rating.

The title you give a presentation will appear in the title region at the 
beginning of the slide show. You can adjust how much time the title shows by 
dragging the title on the storyboard as you would for an image. You can also 
press CTRL+SHIFT+Right Arrow or Left Arrow.

The rest of the information shows in your audience’s players when the 
presentation is loaded. Plus, you can also specify whether you want search 
engines to be able use the information to locate your presentation.

➤ To add information to a project:

1. Choose Edit>Project Properties from the main menu.

The Project Properties dialog opens.

2. Click the Info tab.
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3. Enter the following information. Entering information is optional, but we 
recommend that you fill out each area.

• Title—the title of the clip

• Author—the name of the clip’s creator

• Copyright—year and owner of the clip’s copyright

• Keywords—words that you think your audience would use to search 
for your clip. See “Creating Keywords” on page 47 for tips on creating 
good keywords.

• Description—a brief summary of the clip’s contents

4. Select an audience rating. You have the following choices:

• General - All Ages—suitable for viewing by all audiences; the default 
setting
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• Parental Guidance Recommended—might not be suitable for children 
13 or under

• Adult Supervision Required—not suitable for children under 18

• Adults Only—should not be watched by anyone under 18

5. Select Files Should not be Indexed by Search Engines if you don’t want 
your presentation to be available to people searching for content.

Not selecting this option assigns a unique number to the presentation 
that allows it to be quickly identified by search engines. All presentation 
information is assigned to the unique number and sent to RealNetworks.

6. Click OK to return to the main window, saving your changes.

Choosing a Layout
A layout tells the RealPlayer where the different media regions of your 
presentation will be. You can simply use the default layout if you don’t want to 
worry about the look of your presentation, or you can customize it by moving 
different regions around. This section shows you how to customize your 
layout.

All layout choices are made on the Layout dialog. In this dialog, you choose 
whether you want to use the default or a custom layout, which new regions 
you want to add, and how you want to regions to look.
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The Layout Dialog

The different regions are described below:

• Title Screen is the name of your slide show. This is a text region that 
shows the title at the beginning of the presentation. In the example above, 
this region is depicted by the dotted white lines.

• Pictures is the region where your streaming images appear.

• Text Captions (optional) is the region that contains any captions you 
entered for an image. Although the default layout lists this region, you 
don’t have to use it if you don’t plan on using text captions.

• Text (optional) is the region that contains any text that you want to show 
during the entire slide show. The pictures and captions will change, but 
any text in this region will stay the same.

• Logo (optional) is the region that shows an image during the entire slide 
show. This region is useful for displaying a company icon or background 
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image. Like the Text region, the pictures and captions will change during a 
presentation, but the image in this region will stay the same.

Changing the Size of the Whole Presentation

Before you can add and adjust your regions, you will want to adjust the size of 
the whole presentation to fit all of the regions. The default size is 320 pixels 
wide and 240 pixels high.

➤ To adjust the output presentation size:

1. Choose Edit>Project Layout from the main menu.

The Layout dialog opens with the Default layout selected.

2. Before you can make any changes to the layout, select Custom Layout.

3. Enter a new Width and Height (in pixels) for the presentation. You can 
also drag the width and height bars to the size you desire.

Note

You can only choose presentation sizes between 60 x 60 
and 1024 x 808.

4. Click OK to return to the main window, saving your changes.

Adding New Regions

Simple presentations only contain pictures, a title that appears at the 
beginning of playback, and maybe a caption. If you want to get more creative, 
you can add a Logo region or a Text region.

➤ To add a Logo region:

1. Choose Edit>Project Layout from the main menu.

The Layout dialog opens with the Default layout selected.

2. Before you can make any changes to the layout, select Custom Layout.

3. Select the Include Logo option.

The Logo region appears in the layout area as a small square.

4. Click the Set Image button.

The Image Element Properties dialog opens. In this dialog, you will select 
and edit the image that is used as your logo.
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5. Click the Choose Image button, browse for your image, select it, and click 
OK.

6. You can edit the image in the same way that you edit other images that 
appear in the main presentation. See “Adding Images” on page 9 for more 
information.

7. Select the Make Layout Rectangle Same Size option if you want to force 
the Logo region to be the same dimensions as the image.

8. Click OK to return to the Choose a Layout dialog.

➤ To add a Text region:

1. Choose Edit>Project Layout from the main menu.

The Layout dialog opens with the Default layout selected.

2. Before you can make any changes to the layout, select Custom Layout.

3. Select the Include Text option.

The Text region appears in the layout area.

4. Click the Set Text button.

5. The Text Element Properties dialog opens.

6. Type the text you want to appear throughout the slide show.

7. You can center the text horizontally or vertically by selecting those 
options.

8. If you want to use any ReaText formatting tags, select that option.

The following table lists some standard tags. For a full list, refer to the 
RealText Authoring Guide, which can be found at: 
http://service.real.com/help/library/guides/realtext/realtext.htm.

Common RealText Formatting Tags

RealText Tag Description

<p>...</p> creates a separated paragraph

<br/> add a line break

<center>...</center> centers the enclosed text

<b>...</b> the enclosed text is bold

<i>...</i> the enclosed text is in italics
 (Table Page 1 of 2)
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9. Click OK to return to the Choose a Layout dialog.

Changing a Region’s Size and Location

A good way to give your presentation a custom look is by adjusting the size 
and placement of the different regions. You can experiment with different 
looks and combinations to get a layout that works for you.

Tip
Use the Snap-to Dragging option to quickly line up 
your regions when you adjust them.

➤ To change the look of a region:

1. Choose Edit>Project Layout from the main menu.

The Layout dialog opens with the Default layout selected.

2. Before you can make any changes to the layout, select Custom Layout.

3. Select a region that you want to change in the list of regions.

The region is highlighted in the layout area.

4. You can drag the region to a new location, or you can use the anchors to 
adjust its dimensions.

5. Click OK to return to the main window, saving your changes.

Changing a Region’s Order

When you have many different regions, sometimes they will overlap each 
other. Regions that appear in front of other regions will cover them when the 
final presentation is generated. The list of regions shows the current order; the 
regions at the top of the list are in front of those below them. The Title Screen 
region is always at the top of the list and cannot be moved.

➤ To move a region forward or backward:

1. Select a region that you want to change in the Regions section.

The region is highlighted in the layout area.

<s>...</s> strikes through the enclosed text

<u>...</u> the enclosed text is underlined

Common RealText Formatting Tags (continued)

RealText Tag Description

 (Table Page 2 of 2)
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2. Click the Bring Forward button to move it in front of other regions.

The region moves up in the list.

3. Click the Send Backward button to move it behind other regions.

The region moves down in the list.

4. Click OK to return to the main window, saving your changes.

Saving a Layout

If you want to use your layout for other projects, you can save it using the Save 
As Template button. To use a previously created layout, click on the Load 
Template button.

Choose Your Target Audience
RealSlideshow gives you a few options for choosing a target audience. You can 
choose to create a presentation that will be created for modem users or a 
number of custom audiences.

This section explains what a target audience is, what a SureStream file is, and 
how to select a target audience for your presentation.

About Bandwidth

When you select a specific target audience, you are actually specifying a 
maximum bandwidth for your RealSlideshow presentation at the selected 
target audience. Bandwidth, measured in kilobits per second (Kbps or k), is 
the amount of data that can be sent through an Internet or network 
connection during a set period of time. Standard modems are commonly 
referred to by the bandwidth they are able to receive—for example, 28.8k and 
56k.

In addition to these standard audiences, you can record clips for connection 
speeds of 100k, 200k, or higher. These higher bandwidths, however, are 
generally more typical of corporate Local Area Networks (LANs) or cable 
modems.

Keep in mind that the maximum bandwidth a connection is capable of is 
greater than the real bandwidth carried across it on average. For that reason, 
28k connections actually only use a total bit rate of about 20k, while a 56k 
connection actually uses about 34k.
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About SureStream™

A SureStream file is suited for generating output for more than one target 
audience. SureStream files enable you to create multiple output streams with 
different settings from a single input. All streams exist in a single output file.

For example, you can create a RealAudio clip for both 28k and 56k audiences, 
and RealPlayer G2 will automatically use the correct stream based on the 
user’s connection speed.

A single rate file is only meant for one target audience and is much smaller in 
size. As a result, it takes less hard drive space. But, if your audience connects at 
a lower speed than the file is created for, they will not be able to play your 
single rate file.

How to Select an Audience

Now that you have learned the basics about target audiences, you can decide 
to what audience you want to stream. We recommend that you create 
presentations for 28.8 Kbps and 56 Kbps modem users since the majority of 
Internet users connect at those speeds.

➤ To select a target audience:

1. Choose Edit>Project Properties from the main menu.

The Project Properties dialog opens.

2. Click the Advanced tab.
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3. Choose 28.8 Kbps  and 56 Kbps SureStream to create a presentation for 
both of these audiences. Choose only 28.8 Kbps SureStream if you want to 
create a presentation for just this audience. 

4. If you want a different audience, choose Custom.

5. Select either SureStream or Single Rate.

6. Choose a number of audiences (or one if you chose Single Rate). The more 
audiences you select, the larger your output file size will be.

7. Enter a new bit rate for the RealPix portion of your presentation, if 
desired.

The bit rate you enter should be lower than the overall bit rate of the 
presentation in order to give room for the audio portion (if you have an 
38



RealSlideshow User’s Guide CHAPTER 6: Adjusting Project Properties
audio caption or background music). The following table lists how much 
bit rate “room” you need for your audio stream.

8. Click OK to return to the main window, applying your changes to the 
project.

Audio Bit Rates

Target Audience Bit Rate Used for Audio

28 Kbps Modem 8 Kbps

56 Kbps Modem 20 Kbps

Single ISDN 32 Kbps

Dual ISDN 32 Kbps

xDSL/Cable Modem 32 Kbps

Corporate LAN 32 Kbps
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 Chapter 7: GENERATE THE PRESENTATION
Now that you have added images and sound, and modified the 
presentation to your liking, you are ready to generate the final 
product. This chapter guides you through each step of this process: 
convert the project into RealMedia, play and review the 
presentation, and send the final slide show to others using the 
Internet.

Convert Your Project into RealMedia
This section shows you how to create the output files that you will use to 
stream your presentation to your audience. You will also learn about the 
different files that make up a presentation created with RealSlideshow.

➤ To generate the output files:

1. Click the Generate button.

2. Enter a filename for the SMIL file. This file controls the layout of the final 
presentation.

Tip
Create a new folder for each project. RealSlideshow 
creates a number of files when the presentation is 
generated.

3. Click Save.

RealSlideshow converts the project to a streaming presentation. When the 
conversion is complete, a dialog shows you the different files that are 
generated.

4. Click OK to return to the main window.
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The following table describes the files that are created when you generate a 
RealSlideshow presentation.

If you want to view the presentation, open the SMIL file with your RealPlayer. 
The next section gives you tips on reviewing the presentation.

Play and Review
Once your output is generated, you will want to review your work for yourself. 
You will need a RealPlayer G2 installed to play your presentation.

➤ To play the presentation:

1. In the main window, click the Play button.

Your RealPlayer opens and begins playing your presentation.

2. Review the slide show and note where you want to make changes, if any.

RealSlideshow Files

File Type (extension) Description

HTML (.htm) a basic HTML file that contains a link 
that starts the presentation

SMIL (.smil) the main file for the presentation that 
controls the layout in the RealPlayer; 
do not edit this file unless you are 
familiar with the SMIL language

RealMedia (.rm) encoded RealAudio file; contains your 
music/voice track

Metafile (.ram) a pointer file used by a RealServer to 
launch your presentation

RealText (.rt) encoded RealText files that show your 
presentation’s title at the beginning, 
your text captions, and any other text 
included with the presentation

RealPix (.rp) encoded RealPix file; contains 
information needed to stream your 
images

JPEG (.jpg) JPEG images used during the 
presentation

PNG (.png) PNG images used during the 
presentation
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3. Return to the RealSlideshow main window and make any necessary 
adjustments to your project.

Sending Your Slide Show to the Internet
RealSlideshow allows you to send a generated presentation to a server. This 
server allows any user with a RealPlayer (and access to the server) to be able to 
play your presentation. A simple-to-use wizard guides you through each step 
of the process.

Note

You must have generated a presentation before you can 
publish it.

Using a Service Provider

The easiest way to share your work is to register with a company that will host 
your RealSlideshow presentation. Different publishing profiles exist 
depending on which company (also known as a service provider) you decide to 
choose. These service providers give you access to a RealServer for free or for a 
small fee. Contact your provider’s support for help with publishing.

➤ To use a service provider:

1. From the RealSlideshow main window, click the Send button.

2. The Send Wizard opens.

3. Choose a service provider from the list.

When you make a choice, the account information you must enter 
changes depending on that choice.

4. If you do not already have an account, click the Get an Account or Get an 
Account Password button.

5. Register with your service provider and they will give you a user name and 
password.

6. Enter this information in the spaces provided.

7. You can select whether or not to save the password and bypass this wizard 
in the future.

8. Click the Send button.
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All of the files for your presentation are uploaded to the service provider’s 
Internet server. This process may take a few minutes, depending on the 
speed of your connection.

9. When the upload is completed, you have the following options. Select one 
and click Finish.

• Go to the RealSlideshow sharing page. This page allows you to quickly 
view your slide show, e-mail it to friends and family, and register it 
with search engines.

• Go to your slide show Web page. Selecting this option sends you 
directly to the uploaded Web page that is hosted by your service 
provider. The location is listed at the bottom of the dialog.

• Return to your slide show. This option sends you back to the 
RealSlideshow main window.

Additional Information
For more information regarding data that is 
transmitted to RealNetworks when you select these 
options and what RealNetworks does with this data, see 
our Software Privacy Statement at our Web site: 
http://www.realnetworks.com.

Creating Your Own Web Page

The Web page that launches your slide show is created by RealSlideshow and is 
sent to your service provider when you upload your project’s files. The look of 
this Web page follows a standard template. If you choose to create your own 
Web page or adjust the standard page that is created, follow these tips.

• You must be experienced with HTML before you can adjust or create a 
Web page.

• Your custom Web page must contain a link to a .ram file that launches the 
RealPlayer and plays the slide show. This .ram file is created automatically 
by RealSlideshow and points to the location of the presentation on the 
server. For example:

<a href="test.ram">My Images</a>

Warning
Do not edit the .ram file.
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• We recommend that you give your audience a link to the RealNetworks 
Web site so that they can download the RealPlayer if they do not have the 
latest version installed.

Using a RealServer

If you are streaming your presentation from a RealServer G2, you will need to 
contact your system administrator for vital information. Below is a list of the 
information you need. The items are divided into different sections based on 
the wizard pages that ask for the information.

It may be helpful to print out this list when you contact your system 
administrator.

FTP Server Information—the server where you will upload your Web page

• FTP Server Name: Name or IP address of the file server where your Web 
page will be uploaded. For example: ftp.server.com.

• Directory: Name of the directory on the file server where your Web page 
will be uploaded. For example, if the directory designated by your system 
administrator for uploading files is ftp.server.com/upload, enter upload as 
the directory name. This may be left blank.

• FTP User Name and Password: You may have to enter a name and 
password before you can log on to the FTP server.

Web Server Information—your Web page on the Internet

• Web Server Name: The name of the Web server that will host your Web 
page. For example: www.mysite.com.

• URL Directory: The subdirectory off of the main URL that will contain 
your Web page. If the URL where you have your personal Web site is called 
www.mysite.com/mypage you would enter mypage here.

RealServer FTP Information—the server where you will upload your presentation

• RealServer Name: Name or IP address of the RealServer where you will 
upload your RealMedia files. For example: real.server.com.

• RealServer Directory: Name of the media directory on the RealServer 
where your RealMedia file will be uploaded. For example, if the media 
directory assigned by your system administrator for uploading is called 
real.server.com/media, you would enter media as the directory name.
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• RealServer User Name and Password: You may have to enter a name and 
password before you can log on to the RealServer for uploading.

Media Clip Information—the RealServer that streams your presentation

• RealServer Location: Name or IP address of the RealServer that users 
will use to locate your presentation. This can include the port. For 
example, if the full URL users will use to locate your media file on the 
Internet is rtsp://real.server.com:6060/mypage/file.rm you would enter 
real.server.com:6060 as the RealServer name and port.

• URL Directory: The directory on the RealServer that users will use to 
locate your presentation. For example, if the full URL that users will use 
to locate your media file is rtsp://real.server.com:6060/mypage/file.rm you 
would enter mypage as the URL Directory. 

Using the Wizard

Follow this procedure, using all of the information listed above.

➤ To publish your presentation to a RealServer

1. In the main window, click the Send button.

The Media Upload Wizard opens to the introduction page.

2. Choose Any RealNetworks RealServer from the list of publishing profiles 
and click Next.

3. Enter the FTP server and directory where you will upload the HTML file 
that launches your presentation. Also enter a username and password if 
needed.

4. Click Next.

5. Enter the name of the Web server that will contain your HTML file, plus 
enter a sub-directory if needed.

6. Click Next.

7. Enter the name of the RealServer that you will upload your streaming 
media files to. You may have to enter a directory, username, and password.

8. Click Next.

9. Enter the name of the RealServer that will host your streaming media. 
Enter a directory if needed.
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10. Click Next.

11. You are now ready to upload all of your files. Click Next to begin.

12. Once the upload is complete, click Finish.

Register Your Content
Once you have created a high-quality streaming media clip, you want people to 
watch and listen to it. RealSlideshow gives you the opportunity to add 
keywords to your clips and link to it from a public streaming media guide.

Creating Keywords

RealSlideshow gives you the ability to add keywords to your presentation. 
These keywords help search engines quickly identify your slide show.

Since slide shows are based on images for their content, the only way that your 
audience can search for your presentation is through the keywords that you 
specify. Therefore, choosing the best keywords is vital. Five to ten words 
should be all you need.

For example, if you are creating a RealPix presentation of your vacation to 
Hawaii, the keywords might be:

Hawaii, vacation photos, snorkeling, SCUBA diving, volcano

Adding Your Clip to RealSystem G2 Search Services

A good way for people to learn about your media clip is by using RealSystem 
G2 Search Services. This online guide is hosted by RealNetworks and gives you 
access to all Internet users.

If you choose to register, you will be sent to a Web page that asks you to enter 
information about your clip. This information will point users to your clip 
and where it is being streamed from.

➤ To add a clip to RealSystem G2 Search Services:

1. In the Share Your Slide Show Web page that opens when you have 
finished publishing, choose Register Your Slide Show with RealSystem G2 
Search Services.

Your Web browser opens to the Search Services Web site. Any information 
that you entered when you created your presentation is automatically 
entered in the provided spaces.
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2. Click the Submit button.

Your content is submitted to RealNetworks for review.
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